Pokemon Yellow Sprite Glitches/Not Saving After Battery Replacement


This is my first time posting on a forum so I will try to be specific and thorough. Hopefully I am in the right section. I had seen another forum post on this website with a similar issue to mine, but no solution. Anyways here goes.

My wife had recently obtained a bunch of stuff she had as a kid. Among these items was a game boy advance and several games. One of these games was Pokemon Yellow. I was ecstatic, I popped the game in it wouldn't boot. No matter, I thought, I will just clean the contacts. This started a long series of attempted fixes.

After cleaning the contacts by gently rubbing them with a white eraser and then running over the contacts with 99% isopropyl alcohol i let the cartridge dry. When I popped it back in it booted up! hooray! or not...

So everything boots normally and the sound is there. I can start a new game, which i did, but the first thing I noticed is that right off the bat the sprite for professor oak has been replaced by a glitchy black box (im assuming the placeholder for if the correct sprite is not found). I kept playing and was able to name my character and my rival and the game progressed normally. The overworld sprites look fine, but when I enter a battle all the sprites for all of the characters as well as the pokemon are all replaced by glitchy boxes. the sprites in the pokedex listings are also this way. So then I think, maybe I didn't seat the cartridge correctly so I save the game and shut it down. I re-seat the cartridge and boot it back up, but my save is gone!

At this point, I am a little discouraged, but not hopeless. I order two new cr1616 16 millimeter batteries (this is the battery Yellow uses as it says right above the existing battery on the motherboard). One from Ebay and one from amazon. When they get here, I de-solder the old battery and remove the excess solder from the contact points. I put the new battery into place and solder it in. But still no saving and still glitchy sprites. So i try the other battery and have the same problem. The old battery would not give a reading on my multimeter, but the tho new batteries both read over 3 volts (I know the true reading is obtained by putting the battery under load and testing it, but I do no have the equipment for that. nor do i think the batteries are actually the problem.)

So now I'm thinking, great I have a defective cartridge. So i do a bit of google searching. I came across a forum that suggested reflowing the solder on all of the chips on the board. I checked for dirty or corroded contacts on all of the chips, as well as the contacts that actually go into the game boy. The only thing that seemed somewhat corroded was the MBC3 (the small square on the upper lefthand side of the motherboard if you are holding the motherboard so that the battery is in the upper right hand side). Regardless I reflowed the solder on all of the contact points for all of the chips on the motherboard. I boot it up and BOOM. same problem, no change.

I have also tried placing paper behind the motherboard in the cartridge to push the contacts up a little bit for a better connection. I have an original Gameboy as well and tried playing the game on there to see if the GBA was the problem, but I had the same issues on the original gameboy.

Also, I know this is not a fake or modded copy of the game. I know that gameshark has never been used on it and I know that the missingo/mew/glitch city glitches have never been attempted. (not that missingo actually destroys games in MOST cases, and if it does usually restarting the save files will remedy the issue)

Now I am at a loss, I cannot think of anything else to try short of replacing the chips on the motherboard which is probably beyond my skill level. Does anyone on here have any ideas that I can try? Or do you think this game is worthless? As you can tell I am not your average user and I am open to trying more advance restoration techniques.


Yellow has glitchy sprites during the battle sequences and in the pokedex entries, but the overworld sprites are fine. It also will not save. The contacts have been cleaned thoroughly, the battery has been replaced and soldered in twice with different batteries (not the ghetto tape it up thing), and the solder for all of the chips on the motherboard has been reflowed. It is not a modded or fake copy of the game, has not had gameshark used on it, and none of the famous glitches (missingo, glitch city, etc) have been performed on this cartridge. Any suggestions on what I should try next?
Last edited:
I immediately thought about the ZZAZZ glitch but I think every corrupting-glitch or gameshark code should go away with a new game or a game reset (removing battery should be the best method). It's really weird, also the cartride is not a bootleg you say, check if components and PCB is marked Nintendo just to be sure... but let's assume everything is alright ok?
What I can suggest you is: de-solder battery, close the cartridge, wait a bit, run a new game without battery and check sprites. It should be ok, otherwise we have a serious problem!
If sprites are ok, well turn everything off, reopen the cartridge and solder the battery, then if you have a Mega Memory Card, do a "Erase Game Save" (not necessary, but again, just to be sure 101% there is no savegame), after that, turn off the console and remove the Mega Memory Card, put the cartridge in and run it normally, you should have no saved game and you should be able to save.

If you still have glitched sprites..I don't know really, never heard something like this! The only solution I think is find another Yellow game and throw this away!

Little note: Everytime you test the cartridge, make sure to CLOSE the half back with the half front, regardless of the battery (present or not), don't ask me why but I discovered if you run the game with only back half, it LOOSES the savegame everytime you remove the cartridge... even if there is battery and you have saved.
I was adding a led to a GBC clear cartrige (aswell as a battery replacement) and I wanted to close the cartride shell only once everything was fine, tested and working, so led was working, game was starting, but randomly loosing save game, tried with different batteries same result, was going crazy to solve this maze. The solution was simply running the game with closed shell (don't ask me how is this possible because I refused to understand it...front shell is only a piece of plastic). TLDR: Don't do tests with opened game cartridge, close it everytime.