2 in 1 rumble and memory pak mod


So I run across this 2 in 1 rumble pak on internet and the guy selling it was saying that the memory pak was faulty. I bought it anyway and sure enought the memory pak didn't held any save. After replacing the battery I found out that it would hold small save files(like Tony Hawk 2), but corrupt large ones(like Turok 2). For a while I didn't care and went online to find out how I could make the rumble part batteryless(this is where i ran across this forum) and I did managed to do it, also after that the memory pak started working properly with larger save files, but only for a while. That's when I realised that it could be a faulty capacitor (i heard somewhere that with some heat they come back to working, so maybe that is why after the first mod, with the heat of the solder it worked) and yes, i checked it and it was dead... So I replaced with a new one, but now when in memory pak mode it works fine, but if I switch to rumble mode, not only It doesn't rumble, but also corrupts saved data(again, only larger ones). I was wondering if someone could help me understand what is going on. I'll post a link to the images, I hope it works, :). Thanks a lot !!