Sega Genesis not working...


No Stranger To Love
I just got a Sega Genesis, with an RF box and a power adapter, and 3 games, Sonic the Hedgehog, MK3 and Phantasy Star 3, all for 20$. It isn't working. The system powers up, but when I plug in the RF into the Genesis and the TV, nothing happens. It has to be the RF box, the Genesis, or the TV. Pics:





Like the Atari, getting those old RF boxes working on modern TVs can be a pain. :( There are a LOT of "broken" Atari 2600s going around that simply have trouble with newer TVs.

I am not a huge Sega guy, but here is what I suggest:

First, try using a VCR as a passthrough for the RF. If that does not work, then, try using your input channels with NOTHING else plugged in; channel 3, 4, and all your input channels are where it will show up.

If that fails, look up a wiring diagram and hook up composite to the mobo, it is not that hard, and you will get a better picture, and sound. Do you really want a hollow, crackling "FATALITY! ;)
Try channel 4 instead of channel 3. It worked for me. Jiggle the connector, seriously.
Yes, for sure. Using coax will pick up a LOT of RF (In fact, you can use it as an antenna!), so no wonder the signal is not getting through. ;) If you have no other option, try a really, really short wire.
I had the same problem once with an N64 1st party RF-switch. It was just an original NES one with an adapter, cheap Playstations! Just bought an A/V cable.
Meh. still not working. I have an assortment of pictures to share with you guys :awesome:



Pics of the RF Box and cable




Pics of the console




See anything wrong, people?
Call the number on the "If You Need Help" sticker.

J.D.-"yeah, I got a problem wit mAh genesis, fo shizzle."
Sega-"I'm sorry, those are no longer in production..."
J.D.-"I just need to know how to connect it to my TV"
Sega-*hangs up*
I should actually try that, see what happens. If they answer, I'll record it :lol:
But lets get on topic here, shall we?
I hate to suggest this, as usually it's not the case, but if your cartridge is dirty, the game won't start, and hence no video will be output. The genesis, like many 90s systems, won't even start outputting video of any sort sometimes unless a game is being read perfectly (as the checksum routine has completed itself). Clean the cartridge and the cart port with rubbing alcohol (as close to 100% as you can get) and then try it after it evaporates.